OpenSea réagit à une faille de sécurité dans les smart contracts de Thirdweb

Face à une vulnérabilité de sécurité dans les contrats intelligents de Thirdweb, OpenSea déploie des efforts pour soutenir les utilisateurs concernés dans la migration de leurs contrats.
opensea thirdweb smart contracts
Possédez ce bout d'histoire
Profitez de nombreux avantages en collectionnant nos actualités
  1. OpenSea a collaboré avec Thirdweb pour adresser une vulnérabilité de smart contract, offrant un soutien aux détenteurs de NFT pour la migration de leurs contrats.
  2. Malgré la faille de sécurité, les services de wallet, de paiement et d'infrastructure d'OpenSea restent opérationnels.
  3. La faille concernait des versions spécifiques des contrats AirdropERC20, ERC721 et ERC1155

Réaction d'OpenSea à la faille de sécurité

La marketplace NFT OpenSea a pris des mesures actives en réponse à une faille de sécurité détectée dans les contrats intelligents du toolkit web3, Thirdweb. Cette faille concernait des versions spécifiques des contrats AirdropERC20, ERC721 et ERC1155. Pour aider les détenteurs de NFT affectés, OpenSea a lancé un programme de soutien pour les assister dans la migration de leurs contrats vers des versions plus sécurisées.

Bien que cette vulnérabilité ait suscité des inquiétudes, OpenSea a confirmé que ses services essentiels, y compris les portefeuilles, les paiements et les infrastructures, restaient fiables et pleinement fonctionnels.

Le toolkit web3 Thirdweb indique la démarche à suivre

D'après l'enquête de Thirdweb, la vulnérabilité dans les smart contracts n'a pas encore été exploitée.

Dans la plupart des cas, les mesures consisteront à verrouiller le contrat et à migrer vers un nouveau contrat dépourvu de la vulnérabilité connue. Les mesures exactes à prendre dépendent de la nature de votre contrat intelligent et vous pouvez les déterminer à l'aide de notre outil.

Thirdweb

    Articles qui pourraient vous intéresser